gyro永不抽风

ああああああああああああああああおおおおおおおおおおおおおおおお

HDU 2196 Computers - 树的直径

题目

Computer

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 43138    Accepted Submission(s): 8426


Problem Description
A school bought the first computer some time ago(so this computer's id is 1). During the recent years the school bought N-1 new computers. Each new computer was connected to one of settled earlier. Managers of school are anxious about slow functioning of the net and want to know the maximum distance Si for which i-th computer needs to send signal (i.e. length of cable to the most distant computer). You need to provide this information.


Hint: the example input is corresponding to this graph. And from the graph, you can see that the computer 4 is farthest one from 1, so S1 = 3. Computer 4 and 5 are the farthest ones from 2, so S2 = 2. Computer 5 is the farthest one from 3, so S3 = 3. we also get S4 = 4, S5 = 4.
 

Input
Input file contains multiple test cases.In each case there is natural number N (N<=10000) in the first line, followed by (N-1) lines with descriptions of computers. i-th line contains two natural numbers - number of computer, to which i-th computer is connected and length of cable used for connection. Total length of cable does not exceed 10^9. Numbers in lines of input are separated by a space.
 

Output
For each case output N lines. i-th line must contain number Si for i-th computer (1<=i<=N).
 

Sample Input
5 1 1 2 1 3 1 1 1
 

Sample Output
3 2 3 4 4
 

Author
scnu

题解

我们要求每一个端点最远点,其实就是这个端点到任意一条直径两个端点距离较远的那一个。证明过程其实非常的简单,用反证法就可以。那么,我们其实只需要用两遍dfs求一下直径的两个端点和到一个端点的距离数组求出来,再用一遍dfs把到另外一个端点的距离数组求出来。

注意

多组数据,用while (scanf("%d", &n) != EOF)来做。

代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
#include <iostream>
#include <cstring>
#include <cstdio>

using namespace std;

const int maxn = 10005;

int head[maxn], ecnt = 2, dis[maxn], dis2[maxn];
struct edge { int to, next, w; } g[maxn << 1];
void add_edge(int u, int v, int w) { g[ecnt] = (edge) { v, head[u], w }; head[u] = ecnt ++; }

int n;

int dfs1(int u, int fa) {
int alpha = u;
for (int e = head[u]; e; e = g[e].next) {
int v = g[e].to;
if (v == fa) continue;
dis[v] = dis[u] + g[e].w;
int a = dfs1(v, u);
if (dis[a] >= dis[alpha]) alpha = a;
}
return alpha;
}

int dfs2(int u, int fa) {
for (int e = head[u]; e; e = g[e].next) {
int v = g[e].to;
if (v == fa) continue;
dis2[v] = dis2[u] + g[e].w;
dfs2(v, u);
}
}

int main() {
while (scanf("%d", &n) != EOF) {
memset(head, 0, sizeof(head));
memset(g, 0, sizeof(g));
ecnt = 2;
for (int i = 2; i <= n; i ++) {
int v, w; cin >> v >> w;
add_edge(i, v, w); add_edge(v, i, w);
}
int ds = dfs1(1, 0);
int tmp = dis[ds];
dis[ds] = 0;
int dt = dfs1(ds, 0);
dis2[dt] = 0;
dfs2(dt, 0);
for (int i = 1; i <= n; i ++) cout << max(dis[i], dis2[i]) << endl;
}
return 0;
}
__EOF__
-------------本文结束感谢您的阅读-------------

本文标题:HDU 2196 Computers - 树的直径

文章作者:gyro永不抽风

发布时间:2020年09月22日 - 16:09

最后更新:2020年09月22日 - 17:09

原始链接:http://gyrojeff.moe/2020/09/22/HDU-2196-Computers-%E6%A0%91%E7%9A%84%E7%9B%B4%E5%BE%84/

许可协议: 署名-非商业性使用-相同方式共享 4.0 国际 (CC BY-NC-SA 4.0) 转载请保留原文链接及作者!

真的不买杯奶茶吗?T^T

欢迎关注我的其它发布渠道